Fork me on GitHub

ACM-Dfs搜索-Oil Deposits HDU - 1241

Oil Deposits HDU - 1241

vj原题链接

题目

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits.
GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.
A plot containing oil is called a pocket.
If two pockets are adjacent, then they are part of the same oil deposit.
Oil deposits can be quite large and may contain numerous pockets.
Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. 
Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. 
If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= >100. 
Following this are m lines of n characters each (not counting the end-of-line characters). 
Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. 
Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally.
An oil deposit will not contain more than 100 pockets. 

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0   
1
2
2

AC代码

#include<stdio.h>
#define maxn 1024
char field[maxn][maxn];
//bool book[maxn[maxn];
int n,m;

void dfs(int x,int y)
{
    field[x][y] = '*';

    //循环遍历移动的方向
    for(int dx = -1;dx <= 1;dx++)
    {
        for(int dy = -1;dy <= 1;dy++)
        {
                int nx = x + dx;
                int ny = y + dy;

                //不能越界,且判断是否移动到的点为'w'
                if(nx >= 0 && ny >= 0 && nx <= n && ny <= m && field[nx][ny] == '@')
                    dfs(nx,ny);
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m) == 2 && n &&m)
    {
        for(int i = 0;i<n;i++)
        {
            scanf("%s",&field[i]);
        }

        //memset(book,false,sizeof(book));
        int ans = 0;
        for(int i = 0;i<n;i++)
        {
            for(int j = 0;j<m;j++)
            {
                if(field[i][j] == '@')
                {
                    dfs(i,j);
                    ans++;
                }
            }
        }
        printf("%d\n",ans);
    }
}

反思

  1. 很不幸……我又犯了Presentation Error……又是最后的结果输出时忘记加上\n
  2. 这题简单,与A - Lake Counting POJ - 2386简直一摸一样,代码都几乎不用改,就是字符不同而已……
Adhere to original technology sharing, your support will encourage me to continue to create!